Tech Support Live Chat Inaccessible
Incident Report for Crucial Hosting
Resolved
This is a final update that this incident is now resolved and our Live Chat service (Zopim) is operational.

We appreciate your patience whilst we resolved this matter.
Posted Aug 03, 2015 - 17:29 AEST
Investigating
Be advised our Live Chat service (Zopim) is experiencing intermittent issues and is currently unavailable.

In the mean time you can attempt to submit a ticket by going to https://help.crucial.com.au

We are monitoring the issue and will provide updates in the next 60 min.
Posted Aug 03, 2015 - 16:30 AEST