Mail Delivery Issues on s354.au.crucialx.net
Incident Report for Crucial Hosting
Resolved
This incident is now resolved. Please contact support if you experience any further issues sending or receiving emails.
Posted Nov 04, 2015 - 14:12 AEDT
Investigating
We have identified an issue with the flow of emails for this server. Technicians are working on the issue and will provide further updates within one hour.
Posted Nov 04, 2015 - 13:27 AEDT