Crucial Control Inaccessible - control.crucial.com.au
Incident Report for Crucial Hosting
Resolved
Corrective maintenance has been performed to ensure the ongoing stability of this system.
Posted Dec 05, 2016 - 18:44 AEDT
Monitoring
The Crucial Control Panel (control.crucial.com.au) is now accessible again.

We are investigating the circumstances that lead to the downtime and will continue to closely monitor the system.
Posted Dec 05, 2016 - 16:27 AEDT
Investigating
Be advised our monitoring has indicated there is currently an issue with Crucial Control (control.crucial.com.au).

This will be impacting your ability to pay for invoices, place new orders, manage contacts, access security pins and access the advanced controls for VPS customers.

For customers whom need to contact support we will manually verify you rather than using the PIN.

We are treating this issue as a high priority and will provide an update in the next 30 mins.
Posted Dec 05, 2016 - 16:18 AEDT