Phone Support - Occasional Dropped Calls
Incident Report for Crucial Hosting
Resolved
Be advised we believe this issue has been addressed. Should you have any issues calling us, please contact us by going to help.crucial.com.au
Posted Mar 09, 2015 - 15:40 AEDT
Investigating
Be advised we have had a small number of reports from customers that their calls drop when calling through to our phone support line.

We are actively investigating this issue and are working with our telecoms supplier to identify a root case.

If you do experience this issue, please call back, or contact us via ticket or live chat by going to help.crucial.com.au.
Posted Mar 06, 2015 - 15:49 AEDT