Crucial Control Inaccessible - control.crucial.com.au
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted Mar 27, 2016 - 02:41 AEDT
Investigating
Be advised our monitoring has indicated there is currently an issue with Crucial Control (control.crucial.com.au).

This will be impacting your ability to pay for invoices, place new orders, manage contacts, access security pins and access the advanced controls for VPS customers.
Posted Mar 27, 2016 - 02:41 AEDT