Mail issues due to server blacklisting
Incident Report for Crucial Hosting
Resolved
Mail blacklisting issue has been resolved on the two servers.
Posted May 05, 2015 - 15:09 AEST
Investigating
SH14 and RS20 servers may experience intermittent mail issues as some IPs have been email blacklisted. Technicians are addressing this now.
Posted May 05, 2015 - 13:37 AEST