Help Center Inaccessible - help.crucial.com.au
Incident Report for Crucial Hosting
Resolved
This is a final update that this incident is now resolved. We appreciate your patience whilst we resolved this matter.
Posted May 15, 2015 - 14:57 AEST
Update
Our Help Centre provider (Zendesk) has advised they are working on the issue, thank you for your patience.

Further updates will be posted in approx 60 mins
Posted May 15, 2015 - 13:59 AEST
Update
This is an update that we are still investigating on this.

In meantime,our support team can be reached on 1300 884 839
Posted May 15, 2015 - 13:50 AEST
Investigating
Be advised our Help Center (help.crucial.com.au) , Live Chats and Support Desk are currently unaccessible.

The Help Center is used for submitting tickets, updating tickets, and provides access to the knowledge base area.

We are aware of the issue and are investigating further.

We will update this incident in approx 60 mins.
Posted May 15, 2015 - 12:56 AEST