Crucial Control - Ticket Support
Incident Report for Crucial Hosting
Resolved
The issue has been resolved.
Posted Jun 22, 2016 - 08:38 AEST
Investigating
Be advised, we are currently investigating an issue with submitting tickets via Crucial Control. Our team is working on it with urgency.
We will provide another update in 30 mins or when we have more information.
Posted Jun 22, 2016 - 08:37 AEST