DNS issue : s353.au.crucialx.net
Incident Report for Crucial Hosting
Resolved
This is a final update that this incident is now resolved. We appreciate your patience whilst we resolved this matter.
Posted Jun 29, 2015 - 00:08 AEST
Investigating
There is some DNS issue on the server "s353.au.crucialx.net". Technicians are investigating on it. More updates will follow.
Posted Jun 28, 2015 - 23:43 AEST