Sales and Tech Support Live Chat Intermittent Issues
Incident Report for Crucial Hosting
Resolved
This has been resolved and our chat service is functional.
Posted Apr 28, 2015 - 23:33 AEST
Investigating
Be advised we have identified that customers may be having difficulty accessing our Sales and Tech Support live chat service.

During this time we request customers contact us by submitting a ticket by going to our Help Center (https://help.crucial.com.au).

We are investigating this issue and will provide an update once further information is available.
Posted Apr 28, 2015 - 14:44 AEST