Help Center Unavailable
Incident Report for Crucial Hosting
Resolved
Issued has been fixed and Help Portal is now online.
Posted Jan 06, 2016 - 02:14 AEDT
Update
Technicians have contacted our help center provider and are working towards a resolution for this outage.
Posted Jan 06, 2016 - 01:18 AEDT
Investigating
Our help center is currently unavailable. We are investigating this issue as a priority and will post updates as we receive them.
Posted Jan 05, 2016 - 23:45 AEDT