Support Tickets temporarily unavailable on control.crucial.com.au
Incident Report for Crucial Hosting
Resolved
This issue has now been resolved.
Posted Mar 30, 2016 - 11:03 AEDT
Identified
Be advised that there is currently an issue preventing submission of new tickets on control.crucial.com.au.

We are aware of the issue, have identified the cause and are now working on a fix for this.

We will provide an update in the next 30 minutes.
Posted Mar 30, 2016 - 10:57 AEDT