Phone System Unavailable
Incident Report for Crucial Hosting
Resolved
The network issue has been resolved and the phone support system is now available.
Posted Mar 10, 2017 - 16:57 AEDT
Investigating
We are currently experiencing a network failure which is affecting our phone system.

We are working to resolve this issue.

We will provide an update when it has been resolved.
Posted Mar 10, 2017 - 16:48 AEDT