Phone Support (1300 884 839) Interruption
Incident Report for Crucial Hosting
Resolved
We have confirmation from our upstream provider that this issue has now been resolved.
Posted Dec 20, 2016 - 12:31 AEDT
Monitoring
The intermittent call connectivity issues now appear to have been resolved.
Posted Dec 20, 2016 - 12:22 AEDT
Identified
An upstream provider has identified a signalling failure which is causing intermittent call connectivity issues. Their engineering teams are working to resolve this as soon as possible.

Please contact us via Help Center if necessary, or try calling again as the issue is intermittent.
Posted Dec 20, 2016 - 10:48 AEDT
Investigating
Be advised that Crucial is currently experiencing an interruption to our inbound phone service. Sales and Tech support numbers are working intermittently. Please contact us via Help Center if necessary.

We are currently working to resolve the issue.
Posted Dec 20, 2016 - 10:00 AEDT