Phone Support (1300 884 839) Interruption
Incident Report for Crucial Hosting
Resolved
We have confirmation from our upstream provider that this issue has now been resolved.
Posted Dec 20, 2016 - 15:41 AEDT
Identified
Please be advised that the interruption to our inbound phone service has returned. Sales and Tech support numbers are working intermittently. Please contact us via Help Center if necessary.

Our upstreams are actively working to resolve the issue.
Posted Dec 20, 2016 - 13:23 AEDT