Phone Support - Static Lines / Dropped Calls
Incident Report for Crucial Hosting
Resolved
We have not had any further reports of issues, so we are marking this status event as resolved.
Posted Mar 18, 2015 - 15:53 AEDT
Monitoring
We are continuing to monitor our phone system for any reported issues.
Posted Mar 18, 2015 - 14:56 AEDT
Investigating
Be advised we have had a small number of reports from customers experiencing call drops, static on call or no audio.

We are actively investigating this issue to identify the root cause.

If you do experience this issue, please call back, or contact us via ticket or live chat by going to help.crucial.com.au
Posted Mar 13, 2015 - 11:51 AEDT