Phone system interruption
Incident Report for Crucial Hosting
Resolved
Phone provider connectivity has returned. Phone operation is back to normal.
Posted Apr 02, 2015 - 10:21 AEDT
Investigating
Be advised that Crucial is currently experiencing an interruption to phone service at the phone provider level. Sales and Tech support numbers may not work. Please contact us via Help Center or Live Chats if necessary.
Posted Apr 02, 2015 - 10:03 AEDT