SpamExperts - Email Delivery Delays
Incident Report for Crucial Hosting
Resolved
Mail flow has returned to normal. Please report any further mail flow issues to support.
Posted Dec 09, 2015 - 13:01 AEDT
Identified
The issue has been identified and we expect normal delivery to resume in the next 10 minutes.
Posted Dec 09, 2015 - 12:56 AEDT
Investigating
We are currently experiencing some delays in email delivery. Our systems administrators are investigating this with urgency.
Posted Dec 09, 2015 - 12:45 AEDT