Phone Support Interruption
Incident Report for Crucial Hosting
Resolved
Our upstream voice provider identified and resolved a critical network issue, restoring our phone services.
Posted Feb 20, 2017 - 13:15 AEDT
Identified
Be advised that Crucial is currently experiencing an interruption to our inbound phone service. Sales and Tech support numbers may not work.

Our upstream voice provider is currently working to resolve a critical issue.

Please contact us via Help Center if necessary.
Posted Feb 20, 2017 - 10:49 AEDT