Domain Management - NetRegistry/TPP Wholesale
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted Apr 18, 2017 - 08:18 AEST
Monitoring
Due to an issue with an external domain provider, your domains may not be able to resolve to your services with us. Other domain management services such as new domain registrations, renewals and updates will also be temporarily unavailable.
If your domain is delegated to any nameservers owned by NetRegistry, TPP Wholesale, EzyReg or PlanetDomain you may be experiencing issues.
Posted Apr 13, 2017 - 17:07 AEST