Tech Support Help Center Inaccessible
Incident Report for Crucial Hosting
Resolved
This is a final update that this incident is now resolved and our Help Center is working.

We appreciate your patience whilst we resolved this matter.
Posted Dec 18, 2015 - 00:43 AEDT
Update
We are still investigating this further and will provide updates in approx 60 mins.
Posted Dec 18, 2015 - 00:15 AEDT
Investigating
Be advised we have had reports that our Technical Support Help Center system is currently not working or having intermittent issues.

We are investigating this issue further and will provide updates in approx 60 mins.
Posted Dec 17, 2015 - 22:49 AEDT