Phone-Support Temporarily Unavailable
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted 19 days ago. Nov 22, 2018 - 16:21 AEDT
Investigating
Due to a fire evacuation, our phone support is currently unavailable.

Please contact us through our Help Center if necessary.

https://support.crucial.com.au
Posted 19 days ago. Nov 22, 2018 - 16:00 AEDT
This incident affected: Phone Support.