Client Area Interruption - control.crucial.com.au
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 17:11 AEDT
Update
We are continuing to monitor for any further issues.
Posted Nov 14, 2019 - 17:10 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2019 - 17:10 AEDT
Investigating
Be advised our monitoring has indicated that there is currently an issue with accessing Crucial Control (our billing, contact and security PIN management system).

We are working to resolve this with top priority and will provide an update in 60 minutes, or if there is a significant change in the situation.
Posted Nov 14, 2019 - 17:00 AEDT
This incident affected: Crucial Website.