Phone-Support Unavailable
Incident Report for Crucial Hosting
Resolved
This incident has been resolved. Calls may take longer to be answered than normal for the next few hours as we are experiencing higher than normal call volumes.
Posted Apr 17, 2018 - 11:18 AEST
Investigating
Our systems administrators are currently troubleshooting an infrastructure issue which has caused our phone system to go offline.

Please contact us via Help Center if necessary.
https://help.crucial.com.au/

Please subscribe to this incident to receive an SMS or Email notification when our phone support is operational.
Posted Apr 17, 2018 - 09:17 AEST