Intermittent email deliverability issues due to Blacklisting
Incident Report for Crucial Hosting
Resolved
We have made significant improvements to our outbound spam filtering and have seen a solid improvement on email-deliverability.
Posted Apr 05, 2016 - 16:20 AEST
Update
In the last hour we have again changed the primary IPs used to send email from our servers.

This follows further improvements we have made to our spam filtering servers.

We are continuing to make further improvements to our spam filtering to further reduce the impact of this issue.

We continue to monitor this and will provide updates to this status page as they are available.
Posted Mar 31, 2016 - 09:16 AEDT
Monitoring
Over the last 24 hours we have changed the primary IPs used to send email from our servers.

This follows improvements we have made to the filtering that is done by our spam filtering in addition to actioning a number of abuse and spamming issues.

We are also working on making further improvements to our spam filtering to reduce the impact of this issue.

We will continue to monitor this and will provide updates to this status page as they are available.
Posted Mar 30, 2016 - 09:46 AEDT
Identified
We have become aware of a large increase in the amount of spam originating from our network recently.

This has caused a number of servers in our cluster of outbound mailservers to become blacklisted.

Each mailserver is assigned a range of different IPs and once we have located and addressed the sources of spam, the outbound mail IPs have been swapped.

We have found that the issue keeps on occurring, and have been working to resolve these issues as they appear but have hit the point where this is now impacting a large number of customers.

You may find this is intermittently affecting you as your email is delivered by the different mailservers which may be adversely impacted at the time of mail delivery.

Please be advised that we are fully aware of the issues and are working to resolve them.

We will update this notification once we have made further progress on this.

We apologise for any inconvenience this may cause.
Posted Mar 24, 2016 - 12:38 AEDT