Building Evacuation
Incident Report for Crucial Hosting
Resolved
All staff have returned to the building and we have returned to business as usual.
Posted Jan 30, 2017 - 14:12 AEDT
Identified
Due to a fire evacuation, our phone support is currently unavailable and ticket response times may be longer than usual.

Technical Support is available via tickets. You can reach Technical Support via the Help Centre.
Posted Jan 30, 2017 - 13:56 AEDT