Phone Support (1300 884 839) Interruption
Incident Report for Crucial Hosting
Resolved
This issue has now been resolved. Please contact us on Live Chat if you continue to experience interruptions.
Posted Aug 24, 2015 - 16:24 AEST
Investigating
Be advised that Crucial is currently experiencing an interruption to phone service at the phone provider level. Sales and Tech support numbers may not work. Please contact us via Help Center or Live Chat if necessary.
Posted Aug 24, 2015 - 16:20 AEST