Legacy Shared Servers - Degraded Performance
Incident Report for Crucial Hosting
Resolved
We have identified an authentication issue which has now been resolved.
Posted Sep 06, 2016 - 16:55 AEST
Investigating
We are observing degraded performance on Legacy shared servers,
This may be impacting on the performance of accessing your client's websites, email services, ftp services, WHM and the cPanel control panel.

We are actively investigating this and further updates will follow in the next 60 minutes.
Posted Sep 06, 2016 - 16:38 AEST