Support Tickets Inaccessible
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted Jun 20, 2016 - 23:25 AEST
Identified
Be advised our Support-Ticket System is currently inaccessible.

We are aware of the issue and are investigating further.

We will update this incident in the next 60 minutes.
Posted Jun 20, 2016 - 23:22 AEST