Email Delivery Delays
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 12:07 AEDT
Identified
We are currently experiencing some delays in email delivery. Our systems administrators are investigating this with urgency.
Posted Oct 28, 2019 - 10:36 AEDT
This incident affected: Web Hosting Services and Reseller Hosting Services.