Service Interruption - Shared Hosting Email Failures
Incident Report for Crucial Hosting
Resolved
We have rolled out a fix to all affected servers and this issue is now resolved. If you are still experiencing email deliverability issues, please contact our support team and we will assist you with your inquiry.
Posted Mar 30, 2021 - 18:07 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2021 - 15:53 AEDT
Update
We are continuing to work on this issue with the highest priority. Our Sysadmins are testing a fix and once confirmed working, will be rolled out to the server fleet.

Further updates will be provided within the next 60 minutes or sooner if applicable.
Posted Mar 30, 2021 - 14:59 AEDT
Identified
Be advised that there is currently an issue with the latest cPanel update and how they are configured to communicate with our spam filters.

This may be impacting the deliverability of your emails at this time.

We have identified a fix and are working to roll this out to all servers and resolve this with top priority. We will provide an update as the issue progresses or if there is a significant change in the situation.
Posted Mar 30, 2021 - 11:57 AEDT