Phone Support Interruption
Incident Report for Crucial Hosting
Resolved
This incident has been resolved.
Posted 12 days ago. Oct 06, 2019 - 08:07 AEDT
Investigating
Our Technical Operations team are currently troubleshooting an issue which has caused our phone system to go offline.

Please contact us through our Help Center to submit a support request if necessary.

https://support.crucial.com.au

We are working to resolve this with top priority and will provide an update in 60 minutes, or if there is a significant change in the situation.

You can subscribe to this incident to receive an SMS or Email notification when our phone support is operational.
Posted 12 days ago. Oct 06, 2019 - 07:54 AEDT
This incident affected: Phone Support.