Phone Support Interruption
Incident Report for Crucial Hosting
Resolved
An issue with our primary upstream voice provider meant that customers were unable to successfully navigate our phone system menu. To mitigate the issue, we migrated inbound calls to our backup voice provider whilst our primary provider investigated the problem. However, during this time, only calls to our 1300 numbers were able to successfully be completed.

Once our primary provider resolved the issue, we re-enabled calls to all our inbound numbers, and customers are once again able to successfully navigate our phone system menu.
Posted Nov 07, 2019 - 12:34 AEDT
Update
During our investigations, we have identified that some of our direct numbers are not working. If you'd like to contact us by phone, please call 1300 884 839
Posted Nov 07, 2019 - 09:26 AEDT
Investigating
Our Technical Operations team are currently troubleshooting an issue which has caused our phone system to become unresponsive.

Please login to your Client Account to submit a support request if necessary.

https://support.crucial.com.au

We are working to resolve this with top priority and will provide an update in 60 minutes, or if there is a significant change in the situation.

You can subscribe to this incident to receive an SMS or Email notification when our phone support is operational.
Posted Nov 07, 2019 - 09:09 AEDT
This incident affected: Phone Support.